Android

Bloomberg no longer support the Android 4.4.4 operating system (OS) or below, and the app will cease to work on these devices from December 1, 2017. We recommend users use Android OS 6.0 or higher to ensure future compatibility.

Until that time, users on Android 4.3-4.4.4 may download the 1.1703 version by clicking here.

Users on Android 4.1-4.2 may download the 1.1701 version by clicking here.

Please contact Customer Support for further assistance.